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Read This First 
 
While ElectroCraft believes that the information and guidance given in this manual is correct, all parties 
must rely upon their own skill and judgment when making use of it. ElectroCraft does not assume any 
liability to anyone for any loss or damage caused by any error or omission in the work, whether such error 
or omission is the result of negligence or any other cause. Any and all such liability is disclaimed. 
 
All rights reserved. No part or parts of this document may be reproduced or transmitted in any form or by 
any means, electrical or mechanical including photocopying, recording or by any information-retrieval 
system without permission in writing from ElectroCraft, Inc. The information in this document is subject to 
change without notice. 
 

About This Manual 
 
This document is the software manual for ElectroCraft CompletePower™ Plus Universal servo drives. 
This document covers the download, installation and operation of the ElectroCraft CompleteArchitect™ 
software needed for configuring all ElectroCraft CompletePower™ Plus Universal servo drives. 
 

CompletePowerTM Plus Universal Drive Technical User Manuals 
 

• CPP-A06V48A-SA-USB Technical Reference, ElectroCraft document number 198-0000019. 
 

• CPP-B06V48A-SA-USB Technical Reference, ElectroCraft document number 198-0000019. 
 

• CPP-A12V80A-SA-USB Technical Reference, ElectroCraft document number 198-0000023. 
 

• CPP-A24V80A-SA-USB Technical Reference, ElectroCraft document number 198-0000026.  
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If you Need Assistance … 
 

 
Visit ElectroCraft online  World Wide Web: www.electrocraft.com 

 
If you want to … 

 
 

 
• Receive general information or assistance  

 
• Ask questions about product operation or report suspected problems  

 
• Make suggestions or report errors in documentation 

 
Contact ElectroCraft at … 
 
For North America: 
 

 

Tel 
 

: (844) 338-8114 

Email 
 

: drivesupport@electrocraft.com 

Mail : ElectroCraft 
  2 Marin Way, Suite 3 
  Stratham, NH 03885-2578 
  USA 

 
For Outside North America: 
 
Please visit  

 
 
 
www.electrocraft.com/contact/ 
 

http://www.electrocraft.com/
http://www.electrocraft.com/contact/
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1  Software Overview 
 
This manual covers the download, installation and operation of the ElectroCraft CompleteArchitect™ 
software to configure ElectroCraft CompletePower™ Plus Universal servo drives. 
 

1.1 Key Features 
ElectroCraft CompleteArchitect™ is a Windows®-based software tool that includes the following key 
features: 
 

• Easy installation 

• An Interactive graphical user interface 

• A user configurable motor database 

• Detailed video tutorials 

• An online monitor for visualizing application parameters such as bus voltage and motor speed 

• An oscilloscope for measuring high speed waveforms such as motor phase currents   

• Diagnostic test scripts for verifying control loop parameters 

• I/O monitor to display the physical state of all the digital and analog inputs and outputs  

• Configurable application protection 

• Selectable measurement units 
 

1.2 Simplified Process Flow 
 

Connect the drive to a PC via USB cable

USB Type A - Male USB Mini Type B - Male CPP-AxxVxxA-SA-USB
Drive

Launch 
Software

Download 
Software

Configure the drive and create motion

Connect a power supply and motor to the drive

Install 
Software

 

Figure 1: Simplified Block Diagram 

 
Note: The CPP-AxxVxxA-SA-USB and CPP-BxxVxxA-SA-USB drive can be configured by software 
through USB when no power is supplied to the drive. Power must be applied to the drive before 
operation. 
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1.3 Software Setup 
 

1.3.1 Software Download 
Launch your preferred internet browser and go to the ElectroCraft website. Navigate to the 
CompletePowerTM Plus Universal Drives page to download the CompleteArchitect™ Software. 
 

1.3.2 Software Installation 
Once the download is complete, launch the software installer (ElectroCraft CompleteArchitect Setup 
vxxx.exe). The window shown in Figure 2 will appear.  
 

 

Figure 2: Initial Installation Window 

 
Follow the instructions in the installation window. Once the installation is successfully complete, the 

CompleteArchitect™ software icon   will be accessible from the desktop and Windows Start menu. 
 
 

  

http://www.electrocraft.com/
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1.3.3 Software Launch 
Open CompleteArchitect™. The window shown in Figure 3 will appear. 

 

Figure 3: CompleteArchitect™ Software Initial Window 

Connect the drive to the PC using a USB cable and supply power to the drive. Status will change to 
Connected and the Drive type, Drive serial number, Firmware version and Drive configuration will change 
to reflect the characteristics of the connected drive.  An example of a connected drive is shown in Figure 
4. 

 

Figure 4: Drive Information 
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1.4 Software Window Overview 
The fundamental symbols and sections of the program are labelled  in the example window shown in 
Figure 5.  A description of the function of each fundamental symbol is provided in the accompanying 
table.  The image also highlights the locations and teminology used to describe the different functional 
groups in this document. 
 
 

 

Figure 5: Fundamental Symbols 

 

1.  New project – Create a new project. 

2.  Open project – Open an existing project. 

3.  Save project – Save the current project. 

4.  Rename application - Modify the application name. 

5.  Edit project description – Modify the project description. 

6.  Online monitor – Open the Online monitor tool. 

7.  Oscilloscope – Open the Oscilloscope tool. 

8.  Diagnostic – Open the Diagnostic tool. 

9.  I/O Monitor – Open the I/O Monitor tool. 

10.  Help – Open the most recently viewed help notes. 
Right click any of the drive or motor parameters and select 
Help to open the help window which has a concise 
explanation about the selected parameter. 

11.  Attention – This indicates an issue with a drive setting 

or parameter value. 

 Red Text – Entered value is outside the defined limit 
of the parameter. 

12.  – This status will be displayed when a fault is 
triggered. Click on the status to see which protection 
caused the fault. 

13. – Indicates that the drive is connected to the 
software successfully. The status changes to 

 when the drive is not connected to the 
software. 

14. Disabled – Indicates that the drive is disabled. The status 
changes to Enabled when the drive is enabled. 

15.  Enable drive – Enable the drive.  When the control 
interface is set to “Analog,” this symbol will function as an 
indicator and cannot be toggled. 

16.  Brake/Release drive – Apply Brake. When the control 
interface is set to “Analog,” this symbol will function as an 
indicator and cannot be toggled. 

17.  Reset drive – Reset drive. 
18. Drive type – Displays drive model. 
19. Drive serial number – Displays serial number. 
20. Firmware version – Displays the current firmware version 

of the drive. 
21. Drive configuration – Displays a summary of the 

configuration of the drive. 

22.  Minimize – Minimize the drive status area. 

23.  Read – Read the parameters saved in the drive. 

24.  Write – Write parameters into the drive. In case 
any error, this button will be disabled. 

25.  Resize – Click and drag on this symbol to change 
software window size. 

26.  Checkbox – click a checkbox to enable / disable the 
function.  

 

Tools 
Configuration 

groups 

Drive status area 

15 

16 

12 

11 

Menu 

3 

4 

5 

1 
6 

7 
8 

2 

13 

17 

9 

23 

22 

24 

25 

14 18 

20 

19 

Configuration 
group window 

26 

10 

21 
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1.5 Database Updates 

Electrocraft makes routine updates to the CompleteArchitect™ motor database as new motors become 
available.  The database (DB) and software (SW) can be updated at any time from the tools menu.  
Check the server for updates by clicking Tools -> Check for Updates. The Updates window shown in 
Figure 6 will search the server for all available updates and gives an option to download the latest 
database and software versions. After downloading, click Update to update the software to downloaded 
database version. 

  

Figure 6: Database Update Window 

Click Yes when prompted to close the program as shown in Figure 7. 
 

 

Figure 7: Close Program Confirmation Window 

Click Update and Close in the Updater window as shown in Figure 8. The program will then close.  

 

Figure 8: Updater Window 

Follow similar steps by clicking “Download SW” to download and install the latest software version. 
To confirm that the latest DB was been successfully updated, reopen CompleteArchitect™ and click 
Tools -> Check for DB Updates from the menu.  Confirm that the DB update window indicates that No 
updates available as shown in Figure 9. 
 

 

Figure 9: Database Update Window after Update  
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2 Help 
 

2.1 About 
To view the product version, end user license agreement and open source license list, click Help -> About 
from the menu.  The window shown in Figure 10 will appear. 
 

 

Figure 10: About Window 

 

2.2 Tutorial 
The software contains video tutorials to demonstrate commonly used software features. Select Help -> 
Tutorials from the menu and the window shown in Figure 11 will appear. Select New Project and click 
Start to learn about new project creation. Select Read/Write Configuration and click Start to learn about 
reading, modifying and writing drive parameters. Select New User Motor and click Start to learn about 
creating and storing a custom motor model in the software motor database. 
 
The tutorial will open in the user’s default web browser. 
 

 

Figure 11: Tutorial Select Window  

Click here to view 
tutorial on creating 
New Project 

Click here to view 
tutorial on adding 
new motor to the 
software Motor 
Database 

Click here to view 
tutorial on how to 
Read/Write 
Configuration in the 
drive 

Click start to open 
the tutorial 
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3 Drive Configuration Process Flowchart 
3.1 Flowchart to Configure a Blank Drive or Reconfigure a Drive 

Follow the flow chart below to configure the drive for a BLDC, PMDC or Stepper motor application using 
CompleteArchitect™. Launch the software on a PC and connect the drive to the PC via USB cable. 
Connect the motor and power supply to the drive as described in the Technical user manual.  
 

Note: Following the steps in the flowchart in this section will overwrite the configuration present in the drive. 

Set Control Interface to Analog 
in Motor and Drives group 

Configure Analog I/O group. 
Refer to section 5.5. 

Configure Protections group. Refer to section 5.6. 

Write to drive. Refer to section 3.3.2. 

Configuration 
complete 

Set Control Interface to Step 
and Direction in Motor and 

Drives group 

Select the desired control interface for the application. 

Step and Direction Analog 

Tune Position loop if applicable. 
Refer to section 6.3.6. 

 

Tune Speed loop if applicable. 
Refer to section 6.3.5. 

No 
Is the motor 

in the 
database? 

Select Generic BLDC, 
PMDC or Stepper 

motor. Refer to section 
4.1.3. 

Complete Motor and Drive group 
(Set Control interface to USB). 

Refer to section 5.3. 

Tune Current loop. 
Refer to section 6.3.4. 

Complete Motor and 
Drive group (Set Control 
interface to USB). Refer 

to section 5.3. 

Select motor from 
database. Refer 
to section 4.1.3. 

Yes 

Select the desired motor type for the application. 

Select the drive model and firmware version. Refer to section 4.1.2. 

Create new project. Refer 
to section 4.1.1. 



 

© ElectroCraft 2019 13 CompleteArchitect™ Software Manual 

 

3.2 Flowchart to Read and Save Configuration from Drive 
Follow the flow chart below to save the configuration in the drive into a project for a BLDC, PMDC or 
Stepper motor application using CompleteArchitect™. Launch the software on a PC and connect the 
drive to the PC via USB cable. Connect the motor and power supply to the drive as described in the 
Technical user manual.  
 

 
 

  

No 
Is the motor 

in the 
database? 

Select Generic BLDC,  
PMDC or Stepper 

motor. Refer to section 
4.1.3. 

Select motor from 
database. Refer 
to section 4.1.3. 

Yes 

Select the desired motor type for the application. 

Select the drive model and firmware version. Refer to section 4.1.2. 

Create new project. 
Refer to section 4.1.1. 

Save Project. Refer to section 4.3. 
 

Configuration 
Saved 

Read parameters from drive. Refer to section 3.3.1. 
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3.3 Read and Write from the Drive 
This section will describe the read and write features of the software.  
 

3.3.1 Read 
The read function will load all of the parameters that exist in the connected drive into the software 
interface. Follow the steps shown in Figure 12 to load and verify the parameters present in the drive. 
 

  

Figure 12: Read Drive Parameters 

The error message shown in Figure 13 will be displayed when there is a problem reading the parameters 
from the drive. 

 

 

Figure 13: Read Error Window 

  

Step 1: Click Read. 

Step 2: Click OK. 
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3.3.2 Write 
The Write function will transfer all the parameters of a project into the connected drive. 
CompleteArchitectTM will only allow the user to write to the drive when all of the required fields have been 
filled with values that are within allowable ranges.  When a value falls outside of this range, the value will 
turn red, an exclamation point appears next to the group that needs correction and the “Write” button is 
disabled.  The user must correct all problematic entries before the “Write” button will become enabled. 
Follow the steps shown in Figure 14 and Figure 15 to write all the parameters into drive. 
 

 

Figure 14: Write Drive Parameters 

A prompt window as shown in Figure 15 will appear. Checking the save to EEPROM box will permanently 
write the drive parameters into the drive’s EEPROM.  Leaving the save to EEPROM box unchecked and 
clicking OK will write the parameters into volitile memory and resetting the drive will return the parameters 
to the values saved in EEPROM. 
       

            

Figure 15: Write Prompt Window 

Note that the Save to EEPROM checkbox selection is “sticky”, it retains the previous selection. If the box 
is checked on a write, on the next write operation the box will be checked and vice-versa.  

‘Write’ button. 

Step 2: Click OK. 

Step 1: Check “Save to 
EEPROM” if desired 

Step 3: Click OK. 
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4 Project Menu 
 

4.1 New 
Refer to Section 2.2 to access a video tutorial on creating new project. In this section a new project is 
created which contains one application (refer section 4.6 to add more applications to the same project) 
using a CPP-A12V80A-SA-USB servo drive and a RP17M-8V24-100-D motor as an example.  
 

4.1.1 Name a New Project 
Follow the steps in the Figure 16 to create and name a new project. 
 

 

Figure 16: Creating and Naming New Project 

 

4.1.2 Select the Drive and Firmware version 
Follow the steps in the Figure 17 to select the drive model and firmware version. The drive model and 
firmware version can be found in drive status area as shown in section 1.4. 
 

 

Figure 17: Selecting the Drive and Firmware version 

  

Step 2: Click . 

Step 3: Give the 
project a name. 

Step 1: Verify status is 
Connected. 

Step 5: Give the 
project a description 
if desired. 

Step 6: Click OK. 

Step 4: Select a 
location to save the 
Project. 

Step 7: Select 
Drive model. 

Step 8: Select 
Drive firmware. 

Step 9: Click Motor. 
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4.1.3 Select the Motor 
Follow the steps in the Figure 18 to select the motor model from the ElectroCraft motor database. If the 
specific motor used is not available in the database, a minimally populated project can be created by 
selecting the Generic BLDC motor model.  Selecting this model will require the user to gather additional 
information regarding the operating characteristics of the motor before completing the configuration.  
 

 

Figure 18: Selecting the Motor 

4.2 Open 

To open a project previously created, select Project -> Open or click the  icon from the menu and the 
window shown in Figure 19 will appear. Select the project folder and click Open. 
 

 

Figure 19: Select Project File Window 

Select the project file and click open as shown in Figure 20. 
 

 

Figure 20: Select “.proj” File  

Step 10: Select motor 
type. 

Step 11: Select motor 
model. Step 12: Click Apply. 
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4.3 Save  

To save a project, select Project -> Save or click the  icon from the menu. 
 

4.4 Save as 
To save a project with a different name or in a different location in the computer, select Project -> Save as 
from the menu and the window shown in Figure 21 will appear. Make the necessary changes to the 
project file name, location and description and click OK. 
 

 

Figure 21: Save as Window 

4.5 Close 
To close a project, select Project -> Close Project from the menu. The window shown in Figure 22 will 
appear if the project was not saved prior to closing. Selecting Save will save any changes made to the 
project.  Selecting Discard will close the project without saving any changes.   
 

 

Figure 22: Save Project Prompt 

4.6 New Application 
To create a new application within the same project, select Project -> New Application from the menu. 
The window shown in Figure 23 will appear. Select the drive & motor and click Apply to create the new 
application. 
  

 

Figure 23: Creating New Application  
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4.7 Import Application 
To import an application into the current project from another project, select Project -> Import Application 
from the menu. The window shown in Figure 24 will appear. Open the project file and select the specific 
application and click OK to add the application to the existing project. 
 

 

Figure 24: Importing application 

4.8 Archive 
Archiving a project will bundle all files associated with the project and store them as a single .zip file for 
future use at any location in the computer. The default archive location in the computer is 
“C:\Users\Public\Documents\ElectroCraft\Archives”. 
 
To archive a project, select Project -> Archive from the menu. The window shown in Figure 25 will 
appear. Select the location to archive the project, then click OK and in the progress window click OK 
when the status changes to completed. 
 

 

Figure 25: Archive Project Folder Path and Progress Window 

  

Step 1: Select location to 
store Archived project. 

Step 2: Click OK 

Step 3: Click OK 
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4.9 Extract 
An archived project can be unzipped and restored by extracting the project into any location in the 
computer. To extract a project, select Project -> Extract from the menu. The window shown in Figure 26 
will appear. Select the source archive folder location and target folder for extracted project, then click OK 
and in the progress window click OK when the status changes to completed. 
 

 

Figure 26: Extract Project Folder path and Progress Window 

 

4.10 Settings 
Select Project -> Settings from the menu to open the Settings window shown in Figure 27. The purpose of 
this window is to select different measuring units and languages in the software. Select the Measure or 
General menu and adjust the settings according to the user’s preferences. 
 

 

Figure 27: Project Settings Window  

Step 1: 
Locate 
Archive file 
here. Step 2: Select location 

for the archive file to 
be restored.  

Step 3: Click OK.  
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5 Configuration Groups 
 

5.1 Application Setup 
The Application Setup group shows the drive model number, firmware, motor name and application 
description as shown in Figure 28. The Drive, Firmware and Motor fields are populated from the 
database. The motor name can be edited if desired. The Application Description is a place to enter 
background data to aid in understanding the concept and context of the application. This optional text 
entry is only for the operators use. 
 

 

Figure 28: Application Setup Window 

5.2 Drive Info 
The Drive info group shows the details about the drive. All of the fields in this window are write-protected 
and the data varies depending on the drive selected, an example of this window is shown in Figure 29. 
 

 

Figure 29: Drive Info Window  

 
Add application description 
here if desired 
 

Motor name can be 
edited if desired 
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5.3 Motor and Drive 
The Motor and Drive group allows the user to set the motor and drive parameters for their specific 
application. This configuration group is different for BLDC, PMDC and Stepper motors which are 
discussed below. 
 

5.3.1 Motor and Drive Configuration Group for BLDC Motor 
 The Motor and Drive window for a BLDC motor is shown in Figure 30. 
 

 

Figure 30: Motor and Drive Window for BLDC Motor 

All parameters in this window are described below: 
 
Encoder - When enabled, the encoder will be used for speed and position feedback. When disabled, the 
hall sensors will be used for speed feedback. 
 
Lines per rev – This field represents the resolution of the encoder in units of lines per revolution. An 
encoder datasheet may specify resolution in units of lines, cycles per revolution (CPR), pulses per 
revolution (PPR) or quadrature counts per revolution. Lines, CPR and PPR are same and are often used 
interchangeably.  To convert quadrature counts per revolution to lines, divide by 4. Example: 4000 
quadrature counts = 1000 lines. 
 
Differential - When enabled, the drive enables the differential encoder transceiver.  When disabled, the 
drive will accept a single ended encoder input.  A differential encoder may be more immune to electrically 
noise than a single-ended encoder. Reference the drive’s user manual for electrical connection 
requirements and compatibility. 
 
Use Index - When enabled, the drive will use the encoder index to synchronize motor commutation while 
rotating. This is useful to re-align the sine wave commutation when using single-ended encoders in 
electrically noisy environments.  This option will not compensate for corrupted speed or position feedback 
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due to electrical noise on the encoder signals. This function is recommended for use in current mode 
operation. 
 
Encoder Reverse - Encoder manufacturers do not use a common mechanical convention for “positive” 
direction. Some encoders count positive when turning clockwise (CW) and some when turning counter-
clockwise (CCW). When enabled, this option reverses the polarity of the encoder counting and encoder 
speed reporting. 
 
Hall Sensors: 
Pole pairs – This represents the number of pole pairs that the connected motor possesses. This should 
be listed on the motor datasheet as either Poles or Pole Pairs.  Motor Poles / 2 = Pole Pairs. 
Example: 4 Motor Poles = 2 Motor Pole Pairs. 
 
Hall configuration – This setting is an adjustment to align hall sensor states to the motor phase output 
sequence. Each increment of this variable shifts the commutation alignment by 60 electrical degrees. 
 
The Hall configuration value is divided into two parts: 

• Configurations 0 through 5 = Standard table 

• Configurations 6 through 11 = Alternate table 
 
Each table is separate from the other and circular in function.  Incrementing values for the standard table 
are: 0 - 1 - 2 - 3 - 4 - 5 - 0 - 1 - etc.  Incrementing values for the alternate table are: 6 - 7 - 8 - 9 - 10 - 11 - 
6 - 7 - etc. 
 
Below is the procedure to find the correct Hall configuration for a new motor: 
 

1. Start with Hall configuration = 0 (beginning of the standard hall table). 
2. Disable the encoder to force the drive to use the hall sensors for commutation and speed 

feedback. 
3. Disable the Reverse Spin option. 
4. Configure the drive for current mode. 
5. Setup the analog input command to allow a safe current level. 
6. Enable the drive and observe the motor. 
7. If the motor will not turn, is difficult to turn or seems like the motor wants to hold a position, the 

alternate hall table may be required. Disable the drive and set Hall Configuration = 6 to use the 
alternate table. 

8. If the motor is able to turn, but seems like a reduced torque, increment the Hall configuration by 1. 
9. With the motor spinning, verify that the no-load speed is the same for both directions. 
10. If the motor does not spin the same speed in both directions, increment the Hall configuration by 

1. Repeat step 6. 
11. Verify that the speed reported by the drive is positive when a positive current command is 

applied. It is important that the command input and the reported speed are of the same polarity. 
12. If the polarity of the command and speed are different, increment the Hall configuration by 3 

(creating a 180 electrical degree shift). Remember that the tables are circular and to stay within 
the selected hall table. Example: Incrementing Hall configuration 1 by 3 results in Hall 
configuration 4 (1 -> 2 -> 3 -> 4). Incrementing Hall configuration 5 by 3 results in Hall 
configuration 2 (5 -> 0 -> 1 -> 2). 

13. Verify that the speed reported by the drive is positive when a positive current command is 
applied. 

14. Use the Reverse Spin option to configure whether a positive command produces clockwise (CW) 
or counter-clockwise (CCW) physical rotation of the motor. 

 
A motor should spin with balanced speed in both directions with Hall configurations 0, 1 or 2 for the 
standard hall table or 6, 7 or 8 for the alternate table.  Generally, values of 3, 4 or 5 and 9, 10, or 11 are 
used when the reported speed and command polarity do not match. 
 
As the motor rotates, the hall signal pattern will progress from one state in the table to the next. When the 
hall signal pattern reaches the end of the table, it will loop back to the top.  The motor outputs will 
energize in the sequence shown in the tables below. 
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Note: An increment of 3 within either table will create a shift of 180 electrical degrees, resulting in an 
inversion of the motor outputs. 
 
Standard Commutation Table: 
 

Hall Configuration = 0 

Hall 1 Hall 2 Hall 3 Motor A Motor B Motor C 

0 0 1 x H L 

0 1 1 H x L 

0 1 0 H L x 

1 1 0 x L H 

1 0 0 L x H 

1 0 1 L H x 
 

 Hall Configuration = 1 

Hall 1 Hall 2 Hall 3 Motor A Motor B Motor C 

0 0 1 H x L 

0 1 1 H L x 

0 1 0 x L H 

1 1 0 L x H 

1 0 0 L H x 

1 0 1 x H L 
 

 
Hall Configuration = 2 

Hall 1 Hall 2 Hall 3 Motor A Motor B Motor C 

0 0 1 H L x 

0 1 1 x L H 

0 1 0 L x H 

1 1 0 L H x 

1 0 0 x H L 

1 0 1 H x L 
 

  
Hall Configuration = 3 

Hall 1 Hall 2 Hall 3 Motor A Motor B Motor C 

0 0 1 x L H 

0 1 1 L x H 

0 1 0 L H x 

1 1 0 x H L 

1 0 0 H x L 

1 0 1 H L x 
 

 
Hall Configuration = 4 

Hall 1 Hall 2 Hall 3 Motor A Motor B Motor C 

0 0 1 L x H 

0 1 1 L H x 

0 1 0 x H L 

1 1 0 H x L 

1 0 0 H L x 

1 0 1 x L H 
 

  
Hall Configuration = 5 

Hall 1 Hall 2 Hall 3 Motor A Motor B Motor C 

0 0 1 L H x 

0 1 1 x H L 

0 1 0 H x L 

1 1 0 H L x 

1 0 0 x L H 

1 0 1 L x H 
 

 
Alternate Commutation Tables: 
 

Hall Configuration = 6 

Hall 1 Hall 2 Hall 3 Motor A Motor B Motor C 

0 0 1 H L x 

0 1 1 H x L 

0 1 0 x H L 

1 1 0 L H x 

1 0 0 L x H 

1 0 1 x L H 
 

 Hall Configuration = 7 

Hall 1 Hall 2 Hall 3 Motor A Motor B Motor C 

0 0 1 H x L 

0 1 1 x H L 

0 1 0 L H x 

1 1 0 L x H 

1 0 0 x L H 

1 0 1 H L x 
 

 
Hall Configuration = 8 

Hall 1 Hall 2 Hall 3 Motor A Motor B Motor C 

0 0 1 x H L 

0 1 1 L H x 

0 1 0 L x H 

1 1 0 x L H 

1 0 0 H L x 

1 0 1 H x L 
 

  
Hall Configuration = 9 

Hall 1 Hall 2 Hall 3 Motor A Motor B Motor C 

0 0 1 L H x 

0 1 1 L x H 

0 1 0 x L H 

1 1 0 H L x 

1 0 0 H x L 

1 0 1 x H L 
 

 
Hall Configuration = 10 

Hall 1 Hall 2 Hall 3 Motor A Motor B Motor C 

0 0 1 L x H 

0 1 1 x L H 

0 1 0 H L x 

1 1 0 H x L 

1 0 0 x H L 

1 0 1 L H x 
 

  
Hall Configuration = 11 

Hall 1 Hall 2 Hall 3 Motor A Motor B Motor C 

0 0 1 x L H 

0 1 1 H L x 

0 1 0 H x L 

1 1 0 x H L 

1 0 0 L H x 

1 0 1 L x H 
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PWM Freq. - This option controls the drive output switching frequency. ElectroCraft recommends using a 
lower PWM frequency unless there is a valid reason to use a higher frequency. Higher switching 
frequency will increase the switching losses and reduces the drive efficiency. Refer to the product user 
manual for recommendations and limitations related to PWM Frequency. 
 
Reverse Spin - This option is used to configure whether a positive command produces clockwise (CW) or 
counter-clockwise (CCW) physical rotation of the motor output.  This option does not correct for a polarity 
mismatch in command input vs speed feedback. Use Hall configuration to resolve a polarity mismatch 
with the hall sensors (reference Hall configuration) and Encoder Reverse to resolve a polarity mismatch 
with the encoder (reference Encoder reverse). 
 
Drive operation mode: 
 
Current – This mode configures the drive to run in current control mode. In this mode, the drive operates 
the motor at a commanded current value for a required amount of torque from the motor. Speed of the 
motor is not controlled in this mode. 
 
Speed – This mode configures the drive to run in speed control mode. In this mode, the drive operates 
the motor at a commanded speed. In order to maintain the commanded speed, the current supplied to the 
motor is controlled depending on the load in this mode. 
 
Note: Control interface cannot be Step and Direction for Current and Speed drive operation modes. 
 
Position – This mode configures the drive to run in position control mode. In this mode, the drive 
operates the motor in closed-Loop position control. Position and Current control loops are active in this 
control mode and can be used only with Step and Direction or USB control interface. All position 
commands from Step and Direction or USB interface are immediate. There is no Ramp or Trajectory 
generation in this mode. 
 
Position with Speed – This mode configures the drive to run in position with speed control mode. In this 
mode, the drive operates the motor in closed-Loop position control. Position, Speed and Current control 
loops are active in this control mode and can be used only with Step and Direction or USB control 
interface. All position commands from Step and Direction or USB interface are immediate. There is no 
Ramp or Trajectory generation in this mode. 
 
Note: Control interface cannot be Analog and Drive Mode must be 4-Quadrant for Position and Position 
with Speed drive operation modes. BLDC motors require an encoder for Position or Position with Speed 
mode operation. 
 
Commutation: 
 
Trapezoidal - Trapezoidal or ‘6-step’ commutation mode produces current in the motor by sourcing 
current in one phase, sinking current in another, leaving the third phase  a high impedance state . It is 
recommended for use with ‘Trap-wound’ BLDC motors typically associated with high-speed applications. 
 
Sinusoidal - Sinusoidal commutation produces 3-phase sinusoidal current on all three phase outputs. 
Sinusoidal commutation produces less torque ripple than trapezoidal commutation. Audible motor noise 
may also be reduced while rotating. 
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Drive Mode: 
 
2-Quadrant - 2-Quadrant mode allows the drive to output current to accelerate the motor, but not 
decelerate the motor. This mode is especially useful in unidirectional applications where the motor does 
not need to (or it is best not to) actively decelerate the motor.  Examples of applications where 2-
Quadrant mode may be useful are: Loads with a drive belt and tensioner, a pump, a blower, a grinder or a 
compressor. 
 
4-Quadrant - This mode allows the drive to output current to accelerate and decelerate the motor. This 
mode is used in servo applications where speed overshoot is not desired or when the application requires 
the motor to be actively controlled during deceleration.  
 
Feedback Enhancement: 
 
Hall Compensate – This feature compensates for minor variations of hall signal symmetry for speed 
calculations. It is applicable only when using a BLDC motor with hall switches without an encoder. 
 
Encoder continuously synch to hall - When enabled, the drive will synchronize the encoder to the hall 
sensor 1 while rotating. This is useful to re-align the sine wave commutation when using single-ended 
encoders in electrically noisy environments. This option will not compensate for corrupted speed or 
position feedback due to electrical noise on the encoder signals.  It is recommended only for use in 
current mode operation. 
 
Control Interface: 
 
Control Interface - Selects how a control command is communicated to the drive. 
 
Analog: Sets command source to analog input signals on the I/O connector. Polarity of the command can 
be changed using the Direction digital input. 
 
Step and Direction: Sets command source to Step and Direction digital inputs. 
 
USB: Sets command source to the USB communications port. This mode is used with the Online Monitor 
and Diagnostics tools within CompleteArchitectTM software. 
 
Note: Regardless of the control interface selected, the drive’s digital input ‘Enable’ must be in an enabled 
state for the drive to operate. Refer to the product user manual for details of the Enable input. 
 
Desired Steps per Rev. – For BLDC motors this is the desired number of steps per revolution of the 
motor when in Step and Direction mode. The motor will move one Step for each rising edge on the Step 
digital input. The Step pulse input from the user is converted into encoder counts. The position displayed 
in Online Monitor and Diagnostics are in Encoder Counts (IU = Internal Units). The user may enter any 
value 1 <= steps <= 65535.  The Universal Drive will divide the Desired Steps per Rev. into the Encoder 
resolution.  Step pulse input accuracy on this conversion is +/- 1 encoder count. 
 
Travel limit switch inputs – This feature enables and disables the limit switch functionality of the Limit+ 
and Limit- digital inputs.  When enabled, the Limit+ input will inhibit torque output in the positive direction 
and the Limit- input will inhibit torque output in the negative direction. Refer to the product technical user 
manual for connection details for these inputs. 
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5.3.2 Motor and Drive Configuration Group for PMDC Motor 
The Motor and Drive window for a PMDC motor is shown in Figure 31. 
 

 

Figure 31: Motor and Drive Window for PMDC Motor 

All parameters in this window are described below: 
 
Encoder - When enabled, the encoder will be used for speed and position feedback. When disabled, the 
IxR Speed Feedback Estimator will be used for speed estimation. 
 
Lines per rev – This field represents the resolution of the encoder in units of lines per revolution. An 
encoder datasheet may specify resolution in units of lines, cycles per revolution (CPR), pulses per 
revolution (PPR) or quadrature counts per revolution. Lines, CPR and PPR are same and are often used 
interchangeably.  To convert quadrature counts per revolution to lines, divide by 4. Example: 4000 
quadrature counts = 1000 lines. 
 
Differential - When enabled, the drive enables the differential encoder transceiver.  When disabled, the 
drive will accept a single ended encoder input.  A differential encoder may be more immune to electrically 
noise than a single-ended encoder. Reference the drive’s user manual for electrical connection 
requirements and compatibility. 
 
Use Index - When enabled, the drive will use the encoder index to synchronize motor commutation while 
rotating. This is useful to re-align the sine wave commutation when using single-ended encoders in 
electrically noisy environments.  This option will not compensate for corrupted speed or position feedback 
due to electrical noise on the encoder signals. This function is recommended for use in current mode 
operation. 
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Encoder Reverse - Encoder manufacturers do not use a common mechanical convention for “positive” 
direction. Some encoders count positive when turning clockwise (CW) and some when turning counter-
clockwise (CCW). When enabled, this option reverses the polarity of the encoder counting and encoder 
speed reporting. 
 
IxR Speed Feedback Estimator - This feature estimates motor speed using the motor’s Resistance and 
motor’s back EMF (Ke). It is used when an actual speed feedback device (an encoder or other sensor) is 
unavailable. Refer section 5.3.3 for details. If the Encoder is enabled, the encoder will be used for speed 
and position feedback and IxR Speed Feedback Estimator will not be used. 
 
Motor Resistance - Resistance of the motor winding in units of Ohms. This value can be found on the 
motor datasheet. 
 
Resistance cal. - The Resistance Compensation (Resistance cal) value is used to calibrate the IxR 
speed feedback estimator for speed regulation under changing loads. Refer section 5.3.3 for details. 
 
Motor Ke - This is the motor’s BEMF (Back EMF) voltage constant in units of V/KRPM. This value can be 
found on the motor datasheet. 
 
Ke cal. - The Motor Ke Compensation (Ke cal) value is used to calibrate the IxR Compensation speed 
feedback estimator under steady state no load conditions. Refer section 5.3.3 for details. 
 
PWM Freq. - This option controls the drive output switching frequency. ElectroCraft recommends using a 
lower PWM frequency unless there is a valid reason to use a higher frequency. Higher switching 
frequency will increase the switching losses and reduces the drive efficiency. Refer to the product user 
manual for recommendations and limitations related to PWM Frequency. 
 
Reverse Spin - This option is used to configure whether a positive command produces clockwise (CW) or 
counter-clockwise (CCW) physical rotation of the motor output.  This option does not correct for a polarity 
mismatch in command input vs speed feedback. Use Encoder Reverse to resolve a polarity mismatch 
with the encoder (reference Encoder reverse). 
 
Drive operation mode: 
 
Current – This mode configures the drive to run in current control mode. In this mode, the drive operates 
the motor at a commanded current value for a required amount of torque from the motor. Speed of the 
motor is not controlled in this mode. 
 
Speed – This mode configures the drive to run in speed control mode. In this mode, the drive operates 
the motor at a commanded speed. In order to maintain the commanded speed, the current supplied to the 
motor is controlled depending on the load in this mode. 
 
Note: Control interface cannot be Step and Direction for Current and Speed drive operation modes. 
 
Position – In this mode, the drive operates the motor in position control mode. The Current control loop 
and Position control loops are active in this control mode. Position mode can only be used with Step and 
Direction or USB control interface. All position commands from Step and Direction or USB interface are 
immediate. There is no Ramp or Trajectory generation in this mode.  
 
Position with Speed – This mode configures the drive to run in position with speed control mode. In this 
mode, the drive operates the motor in closed-loop position control. Position, Speed and Current control 
loops are active in this control mode and can be used only with Step and Direction or USB control 
interface. All position commands from Step and Direction or USB interface are immediate. There is no 
Ramp or Trajectory generation in this mode. 
 
Note: Control interface cannot be Analog and Drive Mode must be 4-Quadrant when using Position and 
Position with Speed drive operation modes. PMDC motor requires an Encoder for Position or Position 
with Speed mode operation. 
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Drive Mode: 
 
2-Quadrant - 2-Quadrant mode allows the drive to output current to accelerate the motor, but not 
decelerate the motor. This mode is especially useful in unidirectional applications where the motor does 
not need to (or it is best not to) actively decelerate the motor.  Examples of applications where 2-
Quadrant mode may be useful are: Loads with a drive belt and tensioner, a pump, a blower, a grinder or a 
compressor. 
 
4-Quadrant - This mode allows the drive to output current to accelerate and decelerate the motor. This 
mode is used in servo applications where speed overshoot is not desired or when the application requires 
the motor to be actively controlled during deceleration. 
 
Control Interface: 
 
Control Interface - Selects how a control command is communicated to the drive. 
 
Analog: Sets command source to analog input signals on the I/O connector. Polarity of the command can 
be changed using the Direction digital input. 
 
Step and Direction: Sets command source to Step and Direction digital inputs. 
 
USB: Sets command source to the USB communications port. This mode is used with the Online Monitor 
and Diagnostics tools within CompleteArchitectTM software. 
 
Note: Regardless of the control interface selected, the drive’s digital input ‘Enable’ must be in an enabled 
state for the drive to operate. Refer to the product user manual for details of the Enable input. 
 
Desired Steps per Rev. – For PMDC motors this is the desired number of steps per revolution of the 
motor. The motor will move one Step for each rising edge on the Step digital input. The Step pulse input 
from the user is converted into encoder counts. The position displayed in Online Monitor and Diagnostics 
are in Encoder Counts (IU = Internal Units). The user may enter any value 1 <= steps <= 65535.  The 
Universal Drive will divide the Desired Steps per Rev. into the Encoder resolution.  Step pulse input 
accuracy on this conversion is +/- 1 encoder count. 
 
Travel limit switch inputs – This feature enables and disables the limit switch functionality of the Limit+ 
and Limit- digital inputs.  When enabled, the Limit+ input will inhibit torque output in the positive direction 
and the Limit- input will inhibit torque output in the negative direction. Refer to the product technical user 
manual for connection details for these inputs. 
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5.3.3 IxR Speed Feedback Estimator 
The IxR Speed Feedback Estimator is used to estimate motor speed when an actual speed feedback 
device (an encoder or other sensor) is unavailable. It uses the motor resistance and motor’s BEMF (Back 
EMF) voltage constant (Ke) to estimate the speed of the PMDC motor. When properly adjusted, the 
speed displayed in CompleteArchitect should be close to the motor’s actual speed when measured by an 
external device. IxR Speed Feedback Estimator can be used to monitor the speed of the motor in Current 
operation mode and can be used to input the speed to the speed control loop in Speed operation mode. 
 

 

Figure 32: Example of IxR Speed Feedback Estimator section 

 
Derivation of parameter values 
 
Motor Resistance: This value can be obtained from the motor datasheet. If the data is unavailable, use 
an ohm meter to measure the resistance between the PMDC motor positive and negative terminals when 
the motor shaft is not rotating. Take multiple readings of the resistance value at different motor shaft 
positions and use the average of all measurements as the resistance value. 
 
Resistance cal.: The Resistance Calibration (Resistance cal.) value is used to calibrate the IxR Speed 
Feedback Estimator for speed regulation under changing loads. Increase or decrease this value to 
change the speed estimate of the motor when loaded (lowering the Resistance Cal. reduces motor speed 
and vice versa). Typical range of adjustment is 90% to 110%. A possible way to set Resistance Cal 
parameter value is to lock the motor output shaft and output current to the motor. Adjust Resistance cal. 
value so that speed feedback is zero. This parameter is used with Motor Ke by the IxR Speed Feedback 
Estimator to compute an estimated motor speed. 
 
Motor Ke (Back EMF): This value can be obtained from the motor datasheet. If the data is unavailable, 
look for rated voltage of the motor and maximum motor RPM at no load. Use the equation below to obtain 
the Ke value. Another method is to back drive the motor at a known RPM and measure the voltage 
generated at the PMDC motor positive and negative terminals using volt meter. Use the equation below 
to obtain the Ke value. 

Ke = (Voltage x 1000)/RPM  
 
For example, if the back driven PMDC motor generates 24 V at 10,000 RPM; Ke is found to be 2.4 
V/KRPM using the formula. 

Ke = (24 x 1000)/10,000 = 2.4 V/KRPM 
 
Ke cal.: The Motor Ke Calibration (Ke cal.) value is used to calibrate the IxR Speed Feedback Estimator 
under steady state no load conditions. Increase or decrease this value to change the no-load speed 
estimate of the motor (lowering Ke cal. reduces motor speed and vice versa). Typical range of adjustment 
is 90% to 110%. This parameter is used with Motor Resistance by the IxR Speed Feedback Estimator to 
compute an estimated motor speed. Adjust motor Ke cal. first to calibrate no-load speed and then adjust 
Resistance cal. to calibrate speed regulation for load changes. The recommended procedure to set the 
Ke Cal parameter value is to run motor at no-load and adjust Ke Cal parameter value so that IxR Speed 
Feedback Estimator reported speed equals the actual measured speed. 
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Setting up IxR Speed Feedback Estimator 
 
Step 1: Open the Motor and Drive configuration group in a PMDC project window. 
Step 2: Enter the Motor Resistance and Motor Ke in the appropriate boxes in IxR Speed Feedback 

Estimator section. 
Step 3: Enter 100% in the Resistance cal. and Ke cal. boxes in IxR Speed Feedback Estimator section. 
Step 4: Run the motor at a known RPM without any load and check the motor speed using an external 

speed measuring device like a tachometer. If the speed of the motor displayed in the software is 
greater than the external speed measuring device, then reduce the Ke cal. value until both the 
speed measurements are approximately the same. If the speed displayed in the software is less 
than the external speed measuring device, then increase the Ke cal. value until both the speed 
measurements are approximately the same.  

Step 5: Run the motor at a known RPM with load and check the motor speed using an external speed 
measuring device. If the speed of the motor displayed in the software is greater than the external 
speed measuring device, then reduce the Resistance cal. value until both the speed 
measurements are approximately the same. If the speed displayed in the software is lesser than 
the external speed measuring device, then increase the Resistance cal. value until both the 
speed measurements are approximately the same. 

 
Note: As a PMDC motor heats up, the motor resistance will also increase which causes error in the IxR 
speed feedback estimation. IxR speed feedback is best used for applications where precise control of 
speed is not important. 
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5.3.4 Motor and Drive Configuration Group for Open-Loop Stepper Motor 
The Motor and Drive window for an open-loop stepper motor motor is shown in Figure 33. 
 

 

Figure 33: Motor and Drive Window for Open-Loop Stepper Motor 

All parameters in this window are described below: 
 
Encoder – Not used for open-loop stepper. Checking this box will not have any effect.  
 
Stepper Motor: 
 
Steps per rev. - This is the physical/mechanical Steps per Revolution of the stepper motor. The correct 
value should be listed on the motor datasheet. The User may then select a number of Microsteps per Rev 
for more resolution. 
 
Open-Loop Stepper: 
 
Microsteps / Step - This value divides each physical/mechanical step of a Stepper motor (set by the 
Steps per rev. parameter) into fractional steps. 
 
Moving current - This sets the amount of current that the drive will output to the open-loop Stepper motor 
while the motor is commanded to move. 
 
Standby current - This sets the amount of current that the drive will output to the open-loop Stepper 
motor when the motor has stopped for longer than the Standby Time. 
 
Standby time - This sets the amount of time after the open-loop Stepper motor stops before the drive’s 
output current changes from the Moving Current level to the Standby Current level. 
 
Reverse Spin - This option is used to configure whether a positive command produces clockwise (CW) or 
counter-clockwise (CCW) physical rotation of the motor output.  This option does not correct for a polarity 
mismatch in command input vs speed feedback. 
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Drive operation mode: 
 
From the drop down menu, selecting Open-Loop Stepper configures the application for open-loop mode 
and enables the Open-Loop Stepper parameter group. All other modes in this drop down menu box will 
configure the application for closed-loop stepper mode. 
 
Open-Loop Stepper – In this mode, the drive operates the motor in open-loop position control. The 
Current control loop is active in this control mode. Open-Loop Stepper mode can only be used with Step 
and Direction or USB control interface. All position commands from Step and Direction or USB interface 
are immediate. There is no Ramp or Trajectory generation in this mode. USB commands for Open-Loop 
Stepper motors in Online Monitor are normalized for all Microstep settings to approximately 23 RPM for a 
200 Step per Rev motor. The motor speed is not calculated by the drive. 
 
PWM Freq. - This option controls the drive output switching frequency. ElectroCraft recommends using a 
lower PWM frequency unless there is a valid reason to use a higher frequency. Higher switching 
frequency will increase the switching losses and reduces the drive efficiency. Refer to the product user 
manual for recommendations and limitations related to PWM Frequency. 
 
Commutation – Sinusoidal is the only supported type of commutation for stepper motors and cannot be 
changed.  
 
Drive Mode: 
 
2-Quadrant  / 4-Quadrant - This selection has no effect in open-loop stepper mode. 
 
Control Interface: 
 
Control Interface - Selects how a control command is communicated to the drive. 
 
Analog: Analog is not a valid selection for open-loop stepper and will cause a configuration error if 
selected. 
 
Step and Direction: Sets command source to Step and Direction digital inputs. 
 
USB: Sets command source to the USB communications port. This mode is used with the Online Monitor 
and Diagnostics tools within CompleteArchitectTM software. 
 
Note: Regardless of the control interface selected, the drive’s digital input ‘Enable’ must be in an enabled 
state for the drive to operate with all motor types. Refer to the product user manual for details of the 
Enable input. 
 
Travel limit switch inputs – This feature enables and disables the limit switch functionality of the Limit+ 
and Limit- digital inputs.  When enabled, the Limit+ input will inhibit torque output in the positive direction 
and the Limit- input will inhibit torque output in the negative direction. Refer to the product technical user 
manual for connection details for these inputs. 
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5.3.5 Motor and Drive Configuration Group for Closed-Loop Stepper Motor 
The Motor and Drive window for an closed-loop stepper motor motor is shown in Figure 34: Motor and 
Drive Window for Closed-Loop Stepper Motor. 
 

 

Figure 34: Motor and Drive Window for Closed-Loop Stepper Motor 

All parameters in this window are described below: 
 
Encoder – Required for closed-loop stepper. Unchecking this box in closed-loop stepper will cause a 
configuration error.  
 
Lines per rev – This field represents the resolution of the encoder in units of lines per revolution. An 
encoder datasheet may specify resolution in units of lines, cycles per revolution (CPR), pulses per 
revolution (PPR) or quadrature counts per revolution. Lines, CPR and PPR are same and are often used 
interchangeably.  To convert quadrature counts per revolution to lines, divide by 4. Example: 4000 
quadrature counts = 1000 lines. 
 
Note: In Closed-Loop Stepper mode, the encoder resolution must be a multiple of the stepper motor’s 
Steps Per Rev. (Encoder Lines * 4) / Steps_Per_Rev must be an integer. 
Example 1: (1000 * 4) / 200 = 20. The value of 20 is an integer and is acceptable. 
Example 2: (1024 * 4) / 200 = 20.48. The value of 20.48 is not an integer and is not acceptable. 
 
Differential - When enabled, the drive enables the differential encoder transceiver.  When disabled, the 
drive will accept a single ended encoder input.  A differential encoder may be more immune to electrically 
noise than a single-ended encoder. Reference the drive’s user manual for electrical connection 
requirements and compatibility. 
 
Use Index - When enabled, the drive will use the encoder index to synchronize motor commutation while 
rotating. This is useful to re-align the sine wave commutation when using single-ended encoders in 
electrically noisy environments.  This option will not compensate for corrupted speed or position feedback 
due to electrical noise on the encoder signals. This function is recommended for use in current mode 
operation. 
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Encoder Reverse - Encoder manufacturers do not use a common mechanical convention for “positive” 
direction. Some encoders count positive when turning clockwise (CW) and some when turning counter-
clockwise (CCW). When enabled, this option reverses the polarity of the encoder counting and encoder 
speed reporting. 
 
Stepper Motor: 
 
Steps per rev. - This is the physical/mechanical Steps per Revolution of the stepper motor. The correct 
value should be listed on the motor datasheet. The User may then select a Desired Steps per Rev for 
step resolution required. 
 
Closed-Loop Stepper: 
 
Desired Steps per Rev - This value divides one revolution of a Stepper motor into the required step 
resolution. This parameter sets the size of the angle of rotation for a single step. Example: For Desired 

Steps per Rev = 1000, the motor will rotate 360⁰/1000 = 0.36⁰. Note this value is independent of the 

physical Steps per rev listed on the motor datasheet. If the physical Steps per Rev. is not a factor of both 
Desired Steps per Rev and Encoder Lines per Rev. the actual step size will not be exactly as calculated  
for every step in a revolution due to rounding errors.  
 
A-B Start current - This sets the amount of current that the drive will output to align the motor to phase A 
winding then phase B winding to align the encoder.. 
 
A-B Start time - This sets the time that the A-B Start currentamount of current that the drive will output to 
the open-loop Stepper motor when the motor has stopped for longer than the Standby Time. 
 
 
Reverse Spin - This option is used to configure whether a positive command produces clockwise (CW) or 
counter-clockwise (CCW) physical rotation of the motor output.  This option does not correct for a polarity 
mismatch in command input vs speed feedback.  
 
Drive operation mode: 
 
From the drop down menu only Current, Speed, Position or Position with Speed modes are valid for 
closed-loop stepper. Selecting Open-Loop Stepper will change the mode to open-loop stepper.  
 
Current – This mode configures the drive to run in current control mode. In this mode, the drive operates 
the motor at a commanded current value for a required amount of torque from the motor. Speed of the 
motor is not controlled in this mode. 
 
Speed – This mode configures the drive to run in speed control mode. In this mode, the drive operates 
the motor at a commanded speed. In order to maintain the commanded speed, the current supplied to the 
motor is controlled depending on the load in this mode. 
 
Note: Control interface cannot be Step and Direction for Current and Speed drive operation modes. 
 
Position – In this mode, the drive operates the motor in closed-loop position control. The Current control 
loop and Position control loops are active in this control mode. Position mode can only be used with Step 
and Direction or USB control interface. All position commands from Step and Direction or USB interface 
are immediate. There is no Ramp or Trajectory generation in this mode.  
 
Position with Speed – In this mode, the drive operates the motor in closed-loop position and speed 
control. The Current control loop. Speed control loop and Position with Speed control loops are active in 
this control mode. Position with speed mode can only be used with Step and Direction or USB control 
interface. All position commands from Step and Direction or USB interface are immediate. There is no 
Ramp or Trajectory generation in this mode.  
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PWM Freq. - This option controls the drive output switching frequency. ElectroCraft recommends using a 
lower PWM frequency unless there is a valid reason to use a higher frequency. Higher switching 
frequency will increase the switching losses and reduces the drive efficiency. Refer to the product user 
manual for recommendations and limitations related to PWM Frequency. 
 
Commutation – Sinusoidal is the only supported type of commutation and cannot be changed. 
Drive Mode:   
 
2-Quadrant - 2-Quadrant mode allows the drive to output current to accelerate the motor, but not 
decelerate the motor. This mode is especially useful in unidirectional applications where the motor does 
not need to (or it is best not to) actively decelerate the motor.  Examples of applications where 2-
Quadrant mode may be useful are: Loads with a drive belt and tensioner, a pump, a blower, a grinder or a 
compressor. 
 
4-Quadrant - This mode allows the drive to output current to accelerate and decelerate the motor. This 
mode is used in servo applications where speed overshoot is not desired or when the application requires 
the motor to be actively controlled during deceleration. 
 
Control Interface: 
 
Control Interface - Selects how a control command is communicated to the drive.  
 
Analog: Sets command source to analog input signals on the I/O connector. Polarity of the command can 
be changed using the Direction digital input. 
 
Step and Direction: Sets command source to Step and Direction digital inputs. 
 
USB: Sets command source to the USB communications port. This mode is used with the Online Monitor 
and Diagnostics tools within CompleteArchitectTM software. 
 
Note: Regardless of the control interface selected, the drive’s digital input ‘Enable’ must be in an enabled 
state for the drive to operate with all motor types. Refer to the product user manual for details of the 
Enable input. 
 
Travel limit switch inputs – This feature enables and disables the limit switch functionality of the Limit+ 
and Limit- digital inputs.  When enabled, the Limit+ input will inhibit torque output in the positive direction 
and the Limit- input will inhibit torque output in the negative direction. Refer to the product technical user 
manual for connection details for these inputs. 
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5.4 Control Loops 

The Control Loops group allows the user to adjust the tuning values for current, speed, position and 
position with speed control modes.The default tuning values will vary depending on the drive and motor 
selected when the project was created. An example of this window is shown in Figure 35. 
 

 

Figure 35: Control Loops Window 

Depending on the Drive operation mode selected in the Motor and Drive configuration group, a 
combination of control parameters is enabled and visible. For example, if the user selects “Current” 
operation mode from the Motor and Drive configuration group, the Current control parameters will be 
enabled and visible. The Speed control, Position control, Position with Speed control parameters will be 
disabled and not visible. 
  



 

© ElectroCraft 2019 38 CompleteArchitect™ Software Manual 

All parameters in this group are described below: 
 
Current control:  
 
Current Kp – A value representing the proportional gain for the current PI control loop. 
 
Current Ki - A value representing the integral gain for the current PI control loop. 
 
Current integral limit – Limits the maximum voltage contribution that the integral can make to the current 
PI control loop output. 
 
Current output limit - Limits the maximum voltage output of the current PI control loop. 
 
Note: Output voltage is created using PWM to output a percentage of the power supply voltage. 
Therefore, the measured peak voltage will equal the power supply voltage.  
 
Current ramp - The current ramp is only enabled in current control mode.  It is disabled in all other drive 
operation modes. When enabled, the drive will increase (or decrease) the internal current command 
reference toward the user’s desired current command at this ramp rate. A current ramp value of zero (0) 
disables the current ramp. 
 
Speed control: 
 
Speed Kp - A value representing the proportional gain for the speed PI control loop. 
 
Speed Ki - A value representing the integral gain for the speed PI control loop.  
 
Speed integral limit - This value limits the maximum current contribution the integral can make to the 
speed PI control loop output. 
 
Speed output limit - This value limits the maximum current output of the speed PI control loop. 
Note: The maximum current output of the drive is also limited by the I2T current limit protection settings. 
 
Speed Ramp - The speed ramp is only enabled in speed control mode.  It is disabled in all other drive 
operation modes.  When enabled, the drive will increase (or decrease) the internal speed command 
reference toward the user's desired speed command as a maximum rate indicated by this value. A value 
of zero (0) disables the speed ramp. 
 
Position control: 
 
Position Kp - A value representing the proportional gain for the Position PID control loop. 
 
Position Ki - A value representing the integral gain for the Position PID control loop. 
 
Position Kd - A value representing the derivative gain for the Position PID control loop. 
 
Position Kd Filter - Filter to smooth the derivative contribution to the Position PID control loop. 
 
Position integral limit - Limits the maximum current contribution the integral can make to the Position 
PID control loop output. 
 
Position derivative limit - Limits the maximum current contribution the derivative can make to the 
Position PID control loop output. 
 
Position output limit - Limits the maximum current output of the Position PID control loop. 
 
Note: Current output is also limited by the I2T current limit protection settings.  
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Position with Speed control: 
 
Position speed Kp - A value representing the proportional gain for the Position PID control loop when 
the Speed control loop is active. 
 
Position speed Ki - A value representing the integral gain for the Position PID control loop when the 
Speed control loop is active. 
 
Position speed Kd - A value representing the derivative gain for the Position PID control loop when the 
Speed control loop is active. 
 
Position speed Kd filter - Filter to smooth the derivative contribution to the Position PID control loop 
when the Speed control loop is active. 
 
Position speed integral limit - Limits the maximum speed contribution the integral can make to the 
Position PID control loop output when the Speed control loop is active. 
 
Position speed derivative limit - Limits the maximum speed contribution the derivative can make to the 
Position PID control loop output when the Speed control loop is active. 
 
Position speed output limit - Limits the maximum speed output of the Position PID control loop. 
Note: This is a limit on the maximum speed the motor will be commanded to move to follow a position 
command. 
 
Position and Speed Loop: 
 
Loop frequency – The frequency at which the motor speed is measured and speed control loop is 
calculated. This value must be within the range of 500-20,000Hz. Electrocraft recommends a loop 
frequency of 1000 Hz. 
  
Speed low-pass filter - This feature enables or disables the low-pass filter for speed feedback. 
 

Warning: A filter on the speed feedback can create a 'lag' or 'phase shift' in measured vs actual 
motor speed, resulting in an unstable system. 

 
Speed filter frequency – This value is the response frequency for the speed low-pass filter. The value 
must be slower than the speed loop frequency. 
 
Refer to section 6.3 for diagnostics window where the tuning graph is plotted to evaluate the speed and 
current mode response of the motor with respect to the parameters commanded by the drive. 
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5.5 Analog I/O 
The Analog I/O group allows the user to modify the analog input and output parameters. The analog input 
parameters will be available only when the user selects “Analog” control interface in Motor and Drive 
group. The values entered in all the fields of this section are committed to the drive only after the user 
writes it. 
 

5.5.1 Analog Input for Current Mode 
The Analog I/O configuration group will display current mode parameters when the Drive operation mode 
is selected as “Current” in the Motor and Drive configuration group. An example of Analog I/O window for 
current mode is shown in the Figure 36. 
 

 

Figure 36: Analog I/O Window for Current Mode 

All parameters in this window are described below: 
 
Range  
Analog input configuration. This sets up the linear current command transfer function from low to high 
input voltages. When changes are made the effect can be viewed in the Analog input graph. 
 
Current input high – High level of the input current command in volts at the drive input. Any voltage 
above this value will be interpreted by the drive as the high current command. 
 
Current input low – Low level on the input current command in volts at the drive input. Any voltage 
below this value will be interpreted by the drive as the minimum specified value. 
 
Current command high – Current commanded when the analog input voltage is equal to or above the 
Current input high voltage. 
 
Current command low - Current commanded when the analog input voltage is equal to or below the 
Current input low voltage.   
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Deadband enable 
Deadband configuration on the analog command input. A deadband can be inserted into the analog input 
by defining the current position, width and hysteresis. Any input voltage that falls within the deadband is 
interpreted as a constant output. 
 
Current position – defines the current center the deadband. The deadband can be placed anywhere in 
the current command range to suite the application. A common use is to place a deadband at zero 
current to ensure a zero current command.  
 
Width - This value defines the width of the command input deadband in volts, centered at the current 
position. A width of 0.5 V results in a deadband of +/-0.25 V around the center position. If the deadband 
extends beyond the Range set, only the portion within the range takes effect. 
 
Hysteresis – This value is the amount of voltage added to each side of the deadband width required for 
the command to exit the deadband. This option can be used to reduce dither when the analog input 
command is at or near the edge of the defined deadband. An example graph for Deadband position =0 A, 
Width = 1 V and Hysteresis = 0.1 V is shown in Figure 37. 

0 V

Width = 1 V

0.1 V 
Hysteresis

-0.1 V 
Hysteresis

 

Figure 37: Deadband Hysteresis graph 
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Analog input graph - The input to output scaling of Range and deadband settings is displayed in the 
Analog input graph. The graph reflects any change to the parameter values as soon as its entered in the 
fields.  
 
Figure 38 shows an example where: 

• The drive is setup in current mode  

• The motor input command of +5 V high, -5V low 

• The motor torque command of +1 A high, -1A low 

• Deadband enabled 

• Deadband position = 0 A, Width = 0.5 V, Hysteresis = 0.1 V 
 
These settings place a +/-0.25 V deadband on each side of the zero current command input voltage of 
0V. Any analog input voltage between -0.25V and +0.25V will result in a zero ampere current command. 
The analog input voltage must be greater than 0.25 V + 0.1 V of hysteresis in order to exit the deadband. 
The analog voltage must be less than 0.25 V to re-enter the deadband range. Similarly, input voltage 
must be less than -0.25 V - 0.1 V of hysteresis in order to exit the deadband. The analog voltage must be 
greater than - 0.25 V to re-enter the deadband range. 
 

 
 

 

Figure 38: Analog Input Graph 

  

Deadband 
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5.5.2 Analog Input for Speed Mode 
The Analog I/O configuration group will display speed mode parameters when the Drive operation mode 
is selected as “Speed” in the Motor and Drive configuration group. An example of Analog I/O window for 
speed mode is shown in the Figure 39. 
 

 

Figure 39: Analog I/O Window for Speed mode 

 
All parameters in this window are described below: 
 
Range - The settings input low, input high, command low and command high set the range and scale of 
the analog input. The input to output scaling of these settings can be seen in the Analog Input graph. 
 
Speed input high – This is the maximum voltage accepted by the analog command input. Any voltage 
above this value will be interpreted by the drive as the maximum specified value. 
 
Speed input low – This is the minimum voltage accepted by the analog command input. Any voltage 
below this value will be interpreted by the drive as the minimum specified value. 
 
Speed command high – This is the motor speed desired when the analog input voltage is equal to or 
above the Speed input high voltage specified. 
 
Speed command low - Motor speed desired when the analog input voltage is equal to or below the 
Speed input low voltage specified. 
 
Speed position – This value defines at which position on the Analog input graph to place the deadband. 
This sets the center point of the deadband. A common use is to place the deadband at zero. This allows 
the system the ability to ensure a zero command on the analog input. 
 
Refer section 5.5 for brief explanation on Deadband enable, Width, Hysteresis, Analog input graph. 
  



 

© ElectroCraft 2019 44 CompleteArchitect™ Software Manual 

5.5.3 Analog output  
The drive outputs a ±10 V analog voltage proportional to a user selected drive parameter. The Output 
selection dropdown lists available parameters for selection. The Gain value adjusts the output scaling of 
the analog voltage. The graph displays the output voltage range for the selected parameter. An example 
is shown in Figure 40 of Actual Speed scaled at V/KRPM.  
 

 

Figure 40: Analog Output Graph 
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5.6 Protections 
The Protections group allows the user to enable or modify drive and motor protection parameters. The 
protections window is shown in the Figure 41. Grayed out protections are factory set and cannot be 
changed by the user, the remaining protections can be configured by the user. Some of these protections 
can only be enabled or disabled, others have an associated setting along with being enabled or disabled. 

 

 

Figure 41: Protections Window 

When a Protection is enabled, the drive will shut down with an error if the condition for the Protection is 
met. The error can be read in CompleteArchitect and the drive will also flash a code as described in 
Technical sur manual. In the section below the conditions for the drive to shut down on each Protection is 
covered and the associated setting if applicable. 
 
In the event of a fault during operation, the drive becomes disabled and FAULT will appear in the DRIVE 
Status area and Online Monitor window as shown in Figure 42. Clicking on the FAULT text in either 
window will provide feedback as to which error has been detected. 

 

 

Figure 42: Fault in Drive Status Area 
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Drive hardware error – Not user configurable. An error is detected with the drive hardware. No setting. 
 
Drive software error - Not user configurable. An error is detected with the drive software. No setting. 
 
Configuration error - Not user configurable. An error is detected with the drive configuration. This could 
be a parameter setting out of range or an attempt to change a drive or motor parameter while the drive is 
enabled. No setting. 
 
Phase overcurrent - Not user configurable. An overcurrent is detected. This is typically caused by a 
short circuit or very low resistance condition on the motor outputs. It can also be an indication of 
excessive current loop gains causing the current loop to become unstable and produce large currents or 
high capacitance on motor phases. 
Brake Resistor overpower - Not user configurable The brake resistor is on for too long indicating the 
brake resistor is undersized for the application. Refer to the product technical user manual for 
recommendations and limitations of the brake resistor. 
 
Bus overvoltage - Not user configurable. Internal bus voltage is above the drive maximum voltage limit. 
Usually caused by excessive regeneration in operation indicating the need for a braking resistor or 
undersized braking. Refer to the product technical user manual for electrical specifications and 
recommendations on how to manage regenerated energy during deceleration. 
 
Bus undervoltage - Not user configurable. Internal bus voltage falls below the drive minimum voltage 
limit. Usually caused by power supply inability to supply the current demanded by the drive. Refer to the 
product technical user manual for electrical specifications. 
 
Drive overtemperature - Not user configurable. Drive internal temperature exceeds the maximum 
temperature limit. Usually caused by insufficient cooling. Refer to the product technical user manual for 
environmental, mounting, and power output specifications. 
 
Hall sensor error - User configurable. Invalid hall state or transition is detected by the drive. Error 
detection is not active for PMDC or Stepper motors. This error detector requires hall signals. 
 
Possible causes of a Hall sensor error: 

• Broken hall signal wire 

• Hall signal connector disconnected 

• Electrical noise on the hall signals 

• One or more hall signal is stuck in a state (high or low) 

• Hall signal voltage level is not correct 
 
Refer to the product technical user manual for hall input electrical specifications. 
 
Encoder error - User configurable. Encoder position does not match hall state. Error detection is not 
active for PMDC or Stepper motors. This error detector requires hall signals. 
 
Possible causes of an Encoder error: 

• Encoder disconnected 

• Broken encoder wire 

• Noise on the encoder signals 

• Noise on the hall signals 

• Incorrect Encoder Lines value 

• Incorrect Encoder Reverse setting 

• Incorrect Motor Pole Pairs value 

• Incorrect Hall Configuration value 
 
Refer to the product technical user manual for encoder input electrical specifications. 
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Encoder index error - User configurable. Encoder position does not match index. 
 
Possible causes of an Encoder Index error: 

• Broken encoder wire 

• Noise on the encoder signals 

• Incorrect Encoder Lines value 
 
Refer to the product technical user manual for encoder input electrical specifications. 
 
Motor overtemperature - User configurable. A motor over-temperature condition is detected.  
 
Motor overspeed error – User configurable. Enables or disables detection of a Motor Overspeed error.  
 
Motor overspeed – User setting. Overspeed limit used by Motor Overspeed error. 
 
Control error - User configurable. Enables or disables Speed Control and Position Control error 
protections.  
 
Speed error – User setting. Sets an acceptance window around the commanded speed value. An error is 
detected if actual speed is greater or less than the commanded speed by more than the value set by the 
user for longer than the time period also set by the user. 
 
Speed error time – User setting. Speed error time period that the Speed error is permitted to exceed the 
allowable Speed error. 
 
Position error – User setting. Sets an acceptance window around the commanded position value. An 
error is detected if actual position is greater or less than the commanded position by more than the value 
set by the user for longer than the time period also set by the user. 
 
Position error time – User setting. Position error time period that the Position error is permitted to 
exceed the allowable Position error. 
 
Control error speed time  
I2T Current Limit: This protection is always enabled but is configurable by the user. The default values 
are set by the lower of the drive ratings or motor ratings if a database motor is selected. These values can 
be further configured by the user but will always be limited by the drive rating. 
 
Peak current limit – Peak current (peak of sine) that the drive will output to the motor. This setting is 
normally used to match the motor peak current rating. The drive will supply this current for a configurable 
period. Refer to the product technical user manual for I2T current limit specifications. 
 
Cont. current limit – Continuous current (peak of sine) that the drive will output to the motor after the 
period of Peak current limit expires. This setting is normally used to match the motor continuous current 
rating. Refer to the product technical user manual for I2T current limit specifications. 
 
I2T time – Time period that the drive will output Peak current to the motor. This setting is normally used to  
match the motor power rating. The value entered is restricted by the peak and continuous current limit 
values.  Refer to the product technical user manual for I2T current limit specifications. 
 
The I2T current limit values will be automatically adjusted upon Application creation depending on the 
limits of the motor selected from the database. If the motor’s current limits exceed the drive max limit, the 
values will be limited by the drive and the informational window shown in Figure 43 will appear. 
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Figure 43: Warning window when I2T current limits are adjusted 

 
 
Brake Resistor: This protection is always enabled but is configurable by the user. If the function is not 
required set the On voltage and Off voltage to the drive’s maximum voltage level. Refer to the product 
technical user manual for the maximum voltage limit. 
 
On voltage – The voltage level where the brake resistor output will turn on. This level must be above the 
brake resistor turn off voltage level.  Refer to the product technical user manual for brake resistor 
specifications. 
 
Off voltage – The voltage level where the brake resistor output will turn off. This level must be below the 
brake resistor turn on voltage.  Refer to the product technical user manual for brake resistor 
specifications.  
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6 Tools 
 

6.1 Online Monitor 
The Online Monitor Tool allows the user to monitor parameters of the drive such as the output voltage, 
output current, motor speed, PWM, bus voltage and position.  It also provides a method for controlling the 
drive when the control interface is set to “USB”. 

To open this tool, select Tools -> Online Monitor or select the  icon from the toolbar. 
 

6.1.1 Operating the Drive in USB Mode  
Below are the basic steps required for operating the drive in USB mode: 
 
Step 1: Verify that the Control interface is set to USB in the Motor and Drive group. 
Step 2: Select a Drive operation mode (Current, Speed, Position and Position with Speed) in the Motor 
and Drive group. 
Step 3: Click Write in the Drive Status Area to write all the parameter changes to the drive. 
Step 4: Ensure the “Enable” digital input is pulled to a low state. 
Step 5: Select Online Command from the dropdown list (Current, Speed, Position or Pos. with speed 

depending on the drive operation mode selected) in the Online Monitor window. 
Step 6: Enter an RPM value for a speed command or Ampere value for current command or Positon 

value for Position or Pos. with speed command. 
Step 7: Click Apply and verify that  appears next to the Apply button. 
Step 8: Click  to enable the drive. The motor will begin to run.  
An example of online monitor is shown in Figure 45. 
 
 

 

Figure 44: Motor and Drive configuration window 

  

Step 1 

Step 2 

Step 3 
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Figure 45: Online Monitor Window 

Status area: 
The drive status area shows the status of different characteristics of the drive. Text of the items 1 to 8 will 
turn green when it’s active and black when it’s not. 
 
1. Connected – Drive detected. 7.   V SAT – Speed loop is saturated. 
2. Ready – Drive is ready to start motion. 8.   P SAT – Position loop is saturated. 
3. Enabled –Drive is enabled. 9.   – Appears when a fault is detected. 

 
4. Brake – Brake input is active. 10.  Pause /  Play – This button will pause or 

resume the plots. 

5. Script – Script is running. 11. Temperature – Displays the internal 
temperature of the drive.  

6. I SAT – Current loop is saturated. 12.  Docking and undocking – This will 
dock/undock the tool from the main window. 

  

Status area 
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12 

Step 5 
Step 6  Step 7  

Step 8 
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6.1.2 Plotting Drive Parameters 
The Online Monitor plots the parameters using real-time data at a sampling rate of 100 ms.  This is much 
lower than the drive sampling rate and so will miss some of the data. For this reason this display is used 
to provide an overview of drive operation. The Oscilloscope tool described in section 6.2 is available if 
data at the drive sampling rate is desired. 
 
Adding parameters to monitor: 

Step 1: Select  icon to open “Add Monitoring Parameter” window as shown in Figure 46. 
 

 

Figure 46: Add Monitoring Parameter Window 

Step 2: Click the dropdown arrow  to view the drop down menu and make the desired parameter 
selection, and click OK. 

Step 3: Click the checkbox  to enable or disable plotting. Multiple parameters can be selected and 
plotted simultaneously. The enabled parameters will be plotted by default when it’s initially 
configured.  

Step 4: The plots can be paused using the  icon and resumed using the   icon at the bottom of the 
window. Figure 47 shows an example in which the motor speed, current and position is plotted. 

Step 2 
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Figure 47: Motor Speed and Current Plot 

Deleting monitored parameters: 

• Select  icon. 

• Select the cross icon  for the parameter that has to be deleted and then click the delete symbol 

 as shown in Figure 48. 
 

 

Figure 48: Delete plot  

Step 1 

Step 4 

Step 3 

Delete 

Select 
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6.2 Oscilloscope 
Select Tools -> Oscilloscope or select the  icon in the toolbar menu to open the Oscilloscope tool. The 
purpose of this tool is to observe drive parameters with a higher resolution than available in Online 
Monitor but for lower time periods. The observed parameters can be analyzed for such properties as 
amplitude, frequency, rise time, fall time. The operation of this tool will be familiar to those who have 
worked with Oscilloscopes. 
 

6.2.1 Setup channels 
Follow the steps below to setup the channels of the Oscilloscope: 

• Select Setup Channels and choose up to four different channels for plotting. 

• Select a time base and click OK as shown in Figure 49. This time-base applies to all channels 
 

 

Figure 49: Setup Channels on Oscilloscope 

• Choose the desired color for each channel from the color dropdown list. 

• While operating the motor, click Start Recording to plot the channels. 

• The Units, Units/div and Offset of each channel can be adjusted before or after plotting using the 
arrows or manually entering. 

• There are two vertical cursors on the plot which can be used to find the value of each channel at 
a particular time by selecting Value in Measure options. Cursor can also be used to find the 
difference in values between the two cursors in each channel by selecting Difference in Measure 
options.  

• To move the cursor lines, click and drag the lines to the necessary position. 
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In the examples shown in Figure 50 and Figure 51, the cursors are used to measuring the difference 
between two points in the oscilloscope plot.  The channels are set at 0.5 Units/div and are offset from 
each other by 3 divisions. 
 

 

Figure 50: Trapezoidal Motor Phase Currents Plot 

 

Figure 51: Sinusoidal Motor Phase Currents Plot  
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6.2.2 Save and Load Plots 
Saving a plot: 

• Click the Save button on the right-top corner of the Oscilloscope window. 

• Select a location for the plot and save it either in “.xml” format or “.png” format. Default location to 
save the plot is “C:\Users\Public\Documents\ElectroCraft\Projects\Example\Oscilloscope”. 

Note: Saving plots in “.xml” format can be loaded back into the oscilloscope unlike the “.png” files. 
 
Loading a plot: 

• Click the Load button on the right-top corner of the Oscilloscope window. 

• Navigate to location where the plot was saved, select the file and click Open. 
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6.3 Diagnostic 

Select Tools -> Diagnostic or select the  icon in the toolbar menu to open the Diagnostic tool. The 
purpose of this tool is to help with tuning the drive’s control loops.  
  

6.3.1 Adjusting control loop gains 
When tuning the drive, the proportional gain (Kp), integral gain (Ki) and differential gain (Kd) values are 
changed in the Control Loops group (section 5.4). Use the Diagnostic tool to excite the drive and motor 
(this procedure applies for BLDC, PMDC and Stepper motors) and observe the response. Adjust the gain 
parameters until the system is critically-damped. When Reverse spin checkbox in Motor and Drive group 
is checked, the direction of motor rotation is reversed which in turn reverses the polarity of data in the 
diagnostic graph. 
 

6.3.2 Selecting reference waveform shape 
The shape of reference waveform can be selected from the dropdown list in the diagnostics window. The 
three options available are Unidirectional, Bidirectional and Gap bidirectional. Enter a Current and Speed 
ramp value in the Control loops group depending on the motor and load. The solid line in the Figure 52, 
Figure 53 and Figure 54 represents reference waveforms at ramp value zero and the broken line 
represents reference waveform at ramp value not equal to zero. 
 
A unidirectional reference waveform rises up to the Height specified, stays there for the Width specified 
and then falls to zero. An example of unidirectional reference waveform is shown in Figure 52. 
 

 

Figure 52: Unidirectional Reference Waveform 

A bidirectional reference waveform rises up to the Height specified, stays there for the Width specified 
and then falls to negative value of Height, stays there for the width specified and comes back to zero. An 
example of bidirectional reference waveform is shown in Figure 53. 
 

 

Figure 53: Bidirectional Reference Waveform 

 
  

Ramp = 0 

Ramp ≠ 0 

Ramp = 0 Ramp ≠ 0 
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A gap-bidirectional reference waveform rises up to the Height specified, stays there for the Width 
specified and then falls to zero and stays there for the Width specified and falls to negative value of 
Height, stays there for the width specified and comes back to zero. An example of gap-bidirectional 
reference waveform is shown in Figure 54. 
 

 

Figure 54: Gap-bidirectional Reference Waveform 

 
Note: Diagnostic tool can be used only in USB control interface and the digital input ‘Enable’ must be in 
the Enabled state. 
 

6.3.3 Different types of damped systems 
A system is critically-damped when the actual speed/current of the motor doesn’t overshoot and the 
speed/current of motor responds to changes in a controlled, non-oscillatory manner as shown in Figure 
55. This phenomenon occurs when the correct amount of Kp and Ki gains are applied. 
 
A system is under-damped when the actual speed/current of the motor overshoots and oscillates before 
settling at the reference speed/current. This phenomenon occurs due to high current/speed proportional 
gain (Kp). Example waveform of an under-damped system is shown in Figure 55. 
 
A system is over-damped when the actual speed/current of the motor takes longer time to rise to the 
reference speed/current. This phenomenon occurs due to high current/speed integral gain (Ki). Example 
waveform of an over-damped system is shown in Figure 55.  
 

Time

Reference

Over-Damped

Under-Damped

Critically-Damped

 

Figure 55: Under, Over, Critically Damped Systems 
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6.3.4 Current Loop Tuning 
Current loop tuning: 
Step 1: Select Current under Drive operation mode section in Motor and Drive group. 
Step 2: In the Diagnostic window, select Current PI from the dropdown list. 
Step 3: Select the required Width in milliseconds (default 10 ms), Height in Ampere (default 1 A) and 

Shape of the reference waveform from the dropdown list. 
Step 4: Enter the Current Kp and Ki values in the Control Loops group (It is recommended to set current 

ramp at zero). 
Step 5: Click Write for the parameters to be written into drive. 
Step 6: Click Test and wait until the progress bar gets to 100%.  

- It is recommended that the motor shaft does not turn during tuning (to prevent Back EMF and 
motor commutation from influencing the test).  
- It is also recommended to use 4-Quadrant mode when tuning the current loop to allow full 
control of positive and negative currents. 

 
Repeat steps 4 to 6 if the drive needs better tuning. An example of critically-damped system tuned using 
the software is shown in Figure 56. 
 
 

 

Figure 56: Critically-damped Current Control Loop  
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6.3.5 Speed Loop Tuning 
Speed loop tuning: 
Step 1: Select Speed under Drive operation mode section in Motor and Drive group. 
Step 2: In the Diagnostic window, select Speed PI from the dropdown list. 
Step 3: Select the required Width in mille-seconds (default 1000 ms), Height in RPM (default 1000 RPM) 

and Shape of the reference waveform from the dropdown list. 
Step 4: Enter the Speed Kp and Ki values in the Control Loops group. 
Step 5: Click Write for the parameters to be written into drive. 
Step 6: Click Test and wait until the progress bar gets to 100%. Apply some resistance to the motor shaft. 
 
Repeat steps 4 to 6 if the drive needs better tuning. An example of critically-damped system tuned using 
the software is shown in Figure 57. 
 
 

 

Figure 57: Critically-damped Speed Control Loop 
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6.3.6 Position Loop Tuning 
Position loop tuning: 
Step 1: Select Position under Drive operation mode section in Motor and Drive group. Make sure Reverse 

spin is not checked in Motor and Drive group. 
Step 2: In the Diagnostic window, select Position from the dropdown list. 
Step 3: Select the required Width in mille-seconds (default 1000 ms), Distance in IU (Internal Units = 

Encoder counts, default 1000). Shape of the reference waveform is always unidirectional (not 
user selectable). 

Step 4: Enter the Position Kp, Ki and Kd values in the Control Loops group. 
Step 5: Click Write for the parameters to be written into drive. 
Step 6: Click Test and wait until the progress bar gets to 100%. 
 
Repeat steps 4 to 6 if the drive needs better tuning. An example of critically-damped system tuned using 
the software is shown in Figure 58. 
 
 

 

Figure 58: Critically-damped Position Control Loop 
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6.3.7 Position with Speed Loop Tuning 
Position with Speed loop tuning: 
Step 1: Select Position with Speed under Drive operation mode section in Motor and Drive group. Make 

sure Reverse spin is not checked in Motor and Drive group. 
Step 2: In the Diagnostic window, select Position with Speed from the dropdown list. 
Step 3: Select the required Width in mille-seconds (default 1000 ms), Distance in IU (Internal Units = 

Encoder counts, default 1000). Shape of the reference waveform is always unidirectional (not 
user selectable). 

Step 4: Enter the Position Kp, Ki and Kd values in the Control Loops group. 
Step 5: Click Write for the parameters to be written into drive. 
Step 6: Click Test and wait until the progress bar gets to 100%.  
 
Repeat steps 4 to 6 if the drive needs better tuning. An example of critically-damped system tuned using 
the software is shown in Figure 59. 
 
 

 

Figure 59: Critically-damped Position with Speed Control Loop  

Step 1:  

Step 2 

Step 3 

Step 4 

Step 5 

Step 6 



 

© ElectroCraft 2019 62 CompleteArchitect™ Software Manual 

6.4 Drive I/O Monitor 
The Drive I/O Monitor tool displays the digital input, digital output, analog input, hall sensor states and 
encoder states with position counter.  

To open this tool, select Tools -> Drive I/O Monitor or select the  icon from the toolbar. 
  
Digital Inputs – This section displays the physical state (High-1 or Low-0) of digital inputs. 
  
Digital Outputs – This section displays the physical state (High-1 or Low-0) of digital outputs. 
 
Analog Input – This section displays the analog input which is scaled according to Analog I/O 
configuration group’s parameter settings. If the analog input is not used for the selected drive operation 
mode, then it’s disabled on the Drive I/O Monitor. 
 
Hall Sensors – This section displays the status of hall sensor inputs. For a BLDC motor it shows the 
status of the inputs. Even though Stepper and PMDC motors do not have hall sensors, the display is still 
active and will report the status of the inputs. 
 
Encoder – This section displays the status of encoder inputs. The scaling of the dial (counts per rotation) 
is based on the user entered encoder Lines per rev value. This section is active only if the encoder 
checkbox on the Motor and Drive configuration group is checked.   
 
An example of online monitor is shown in Figure 60 
 

 

Figure 60: Drive I/O Monitor 
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6.5 User Motor Database Manager 
Select Tools -> User Motor DB Manager from the menu to open the User Motor Database tool, the 
window shown in Figure 61 will appear. The purpose of this window is to add a user’s custom motor into 
the software database. 
 

 

Figure 61: User Motor Database Manager Window 

 

6.5.1 Add New Motor to the Database 
• Select New in the User Motor Database Manager window and select the desired motor type from 

the list and click OK as shown in Figure 62. Brushless DC motor is selected to demonstrate this 
tool. 

 
 
 

 

Figure 62: New Motor Type Selection Window  

Select the desired motor 
and click OK 

Click New 
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• The Motor settings window will appear in which all motor parameters need to be entered (for 
unknown parameter values, follow the suggestions specified next to each unit) as shown in 
Figure 63 and click OK. 

 

 

Figure 63: Motor Settings Window 

• The motor should now be displayed in the User Motor Database Manager window as shown in 
Figure 64. The selected motor appears in red text. 

 

 

Figure 64: New Motor Added to Database 

• If the motor was successfully entered into the database, it will be displayed in alphabetical order 
in the New Application window as shown in Figure 65.  

 

  

Figure 65: New Motor displayed while creating new project  
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motor 

Newly added 
motor 
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6.5.2 Edit or Delete Motor from the Database 
Edit a motor in the database: 

• Open the User Motor Database Manager window and select the motor to be edited and click Edit 
as shown in Figure 66. 

 

 

Figure 66: Edit Motor 

• The Motor Settings window will appear in which all the motor parameters can be edited and click 
OK to finalize changes. 

 
Delete a motor from user motor database: 

• Open the User Motor Database Manager window and select the motor to be deleted and click 
Delete. Click OK in the information window as shown in Figure 67. This will delete the selected 
motor from the user motor database. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 67: Delete Motor 

 

6.6 Check for Database updates 
Refer to section 1.5 for the steps to update the database.  

Select the motor 
and click Edit 

Select the motor 
and click Delete 
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